Intel® Storage System
SSR212PP

Based on EMC AX150® Technology

PowerPath for Windows Version 4.5

Installation and
Administration Guide

Intel Order Number D59959-001



Disclaimers

Information in this document is provided in connection with Intel® products. No license, express or
implied, by estoppel or otherwise, to any intellectual property rights is granted by this document.
Except as provided in Intel's Terms and Conditions of Sale for such products, Intel assumes no
liability whatsoever, and Intel disclaims any express or implied warranty, relating to sale and/or use
of Intel® products including liability or warranties relating to fithess for a particular purpose,
merchantability, or infringement of any patent, copyright or other intellectual property right. Intel
products are not designed, intended or authorized for use in any medical, life saving, or life
sustaining applications or for any other application in which the failure of the Intel product could
create a situation where personal injury or death may occur. Intel may make changes to
specifications and product descriptions at any time, without notice.

Intel® server boards contain a number of high-density VLSI and power delivery components that
need adequate airflow for cooling. Intel's own chassis are designed and tested to meet the intended
thermal requirements of these components when the fully integrated system is used together. It is
the responsibility of the system integrator that chooses not to use Intel developed server building
blocks to consult vendor datasheets and operating parameters to determine the amount of airflow
required for their specific application and environmental conditions. Intel Corporation can not be held
responsible if components fail or the server board does not operate correctly when used outside any
of their published operating or non-operating limits.

Copyright © 2006, Intel Corporation. All Rights Reserved

Copyright© 2005-6 EMC Corporation. All Rights Reserved.

Trademark Information

Intel, Intel Pentium, and Intel Xeon are trademarks or registered trademarks of Intel Corporation or
its subsidiaries in the United States and other countries.

EMC2, EMC, CLARIIiON, Navisphere, and PowerPath are registered trademarks and Access Logix,
FLARE, MirrorView, SAN Copy, and SnapView are trademarks of EMC Corporation.
All other trademarks mentioned herein are the property of their respective owners.

Intel Storage System SSR212PP PowerPath 4.5 for Windows: Installation and Administration Guide



Contents

List of Figures \
List of Tables vii
Preface IX
Audience and PrereqUISIteS. . . ..ottt iX
Additional Information and Software . . ... ... . . iX
Chapter 1. Installing PowerPath 4.5 for Windows 1
PowerPath and PowerPath iISCSI . . . .. ... 1
Before You Install . .. ... 2
Installing PowerPath Using InstallShield . . . ....... ... . 4
Installing PowerPath from the Command Line . .......... .. ... . . . . . . .. 6
After You Install . .. ..o 9
Installing a PowerPath Patch. . . ... ... 10
Upgrading Windows Operating SYStemsS . . . . . . ..ot 11
Licensing TOOl . . . ..o 12
Chapter 2. Removing PowerPath 4.5 for Windows 13
Before You Remove PowerPath . . ... ... . 13
Removing PowerPath from a Windows HOSt. . . .. ... .. 13
Removing PowerPath Using Add/Remove Programs . . .. ... .ottt 14
Removing PowerPath from the Command Line .. ........ ... . . . . ., 14
Chapter 3. PowerPath 4.5 for Windows Administrator 17
OVBIVIBW .« o o sttt e e e e e e e e 17
PowerPath MOnitor . . ... .. 17
PowerPath Administrator. . . .. ... 19
Local or Remote AdmINIStration. . . .. ... .. e 24
Saving Console SettiNgS . . ... oo 32
Chapter 4. PowerPath in an MSCS Cluster 33
Installing PowerPath and MSCS . . . .. ... 33
Integrating PowerPath into an Existing MSCS Cluster . ............ .. .. 33

Intel Storage System SSR212PP PowerPath 4.5 for Windows: Installation and Administration Guide iii



Appendix A. WHQL Certification 37

WHQL-Certified DriVer. . . ... e 37
Appendix B. List of Files Changed by PowerPath 39
File Changes on Windows 2000 and Windows Server 2003. . . .. .. ...ttt 39
Driver Files Installed Into System DireCtories . . ... ...t e 41
Registry Changes Caused by PowerPath Installation. .. ............. ... .. ... .. ....... 42
Index 43

iv

Intel Storage System SSR212PP PowerPath 4.5 for Windows: Installation and Administration Guide
Revision 1.0



List of Figures

Figure 1. Sample PowerPath Administrator Display . . ... ... e 19
Figure 2. Cluster AdminiStrator . . . ... ...t e e e 34

Intel Storage System SSR212PP PowerPath 4.5 for Windows: Installation and Administration Guide v



Vi Intel Storage System SSR212PP PowerPath 4.5 for Windows: Installation and Administration Guide
Revision 1.0



List of Tables

Table 1
Table 2
Table 3
Table 4
Table 5
Table 6
Table 7
Table 8
Table 9

Silent Installation Variables . . .. ... ... e 7
Optional Properties . . ... 8
Interactive Installation Variables . . ......... .. . . . 9
Silent Removal Variables. . . ... ... . e 15
Optional Properties . .. ... e 15
Interactive Removal Variables . . . ... . . 16
PowerPath Monitor Taskbar Icons. . .. ... .. . 18
PowerPath Administrator ICONS . . . ... .. e 21
PowerPath Administrator Object ICONSs . ............ . . e 23

Intel Storage System SSR212PP PowerPath 4.5 for Windows: Installation and Administration Guide Vil



viii Intel Storage System SSR212PP PowerPath 4.5 for Windows: Installation and Administration Guide
Revision 1.0



Preface

Some functions described in this manual may not be supported by all versions of
PowerPath or the storage-system hardware it supports. For the most up-to-date
information on product features, see your product release notes.

This guide describes how to install and remove PowerPath 4.5.x for Windows 2000 and
Windows Server 2003. It also includes an introduction to the PowerPath Administrator.

Audience and Prerequisites

This manual is part of the PowerPath documentation set. It is intended for use by storage
administrators and other information system professionals responsible for installing,
using, and maintaining PowerPath.

Readers of this manual are expected to be familiar with the host operating system, storage-
system management, and the applications used with PowerPath.

Additional Information and Software

If you need more information about this product or information about the accessories that
can be used with this storage system, use the following resources. These files are available
at http://support.intel.com/support/motherboards/server/SSR212PP. Unless otherwise
indicated in the following table, once on this Web page, type the document or software
name in the search field at the left side of the screen and select the option to search "This

Product."
For this information or -
Use this Document or Software
For in-depth technical Intel® Storage System SSR212PP Technical Product Specification
information about this
product
If you just received this Intel® Storage System SSR212PP Quick Start User's Guide in the
product and need to product box
install it
For virtual system tours A link to the SMaRT Tool is available under "Other Resources" at the
and interactive repair right side of the screen at
information http://support.intel.com/support/motherboards/server/SSR212PP
Accessories and spacres Intel® Storage System SSR212PP Spares Installation Guide

Intel Storage System SSR212PP PowerPath 4.5 for Windows: Installation and Administration Guide ix


http://support.intel.com/support/motherboards/server/

00 U DU imeiies € Use this Document or Software

software

Hardware (peripheral Tested Hardware Operating Systems List (THOL)

boards, adapter cards)
and operating systems
that have been tested
with this product

Intel Storage System SSR212PP PowerPath 4.5 for Windows: Installation and Administration Guide
Revision 1.0



Installing PowerPath 4.5 for
Windows

This chapter describes procedures for installing and upgrading PowerPath on a Windows
2000 or Windows Server 2003 host. The topics include:

m  "PowerPath and PowerPath iSCSI" on page 1

m  "Before You Install" on page 2

m  "[nstalling PowerPath Using InstallShield" on page 4
m  "After You Install" on page 9

m '"Installing a PowerPath Patch" on page 10

m  "Upgrading Windows Operating Systems" on page 11
m  "Upgrading Windows Operating Systems" on page 11

m  "Licensing Tool" on page 12

PowerPath and PowerPath iSCSI

PowerPath” for Windows software is available in two different packages: PowerPath for
Windows and PowerPath iSCSI for Windows. It is important to know the differences
between the two packages before deploying the software:

m  PowerPath for Windows supports both Fibre Channel and iSCSI environments.
PowerPath for Windows is Microsoft digitally certified only for Fibre Channel
environments. PowerPath for Windows supports failover path management and load-
balancing for up to 32 paths in heterogeneous storage environments.

PowerPath for Windows is not currently supported by Microsoft for iSCSI
implementations, although it is supported iSCSI storage systems.

m  PowerPath iSCSI for Windows supports iSCSI storage systems. PowerPath iSCSI
for Windows is Microsoft digitally certified and is built on the Microsoft MPIO
framework. PowerPath iSCSI for Windows supports failover path management for up
to 8 paths in iSCSI storage environments.

Refer to PowerPath iSCSI for Windows: Getting Started for more information on
PowerPath iSCSI for Windows. This guide is available on the SSR212PP support
website (http://support.intel.com/support/motherboards/server/SSR212PP).

Intel Storage System SSR212PP PowerPath 4.5 for Windows: Installation and Administration Guide 1
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Before You Install

The sequence of steps to configure a storage system and install PowerPath on a host
depends on the storage system you use.

m  SSR2]2PP-Series storage systems. PowerPath installation is an integral part of the
setup and configuration procedure.

SSR212PP-Series installation, planning, and troubleshooting documents are located
on the SSR212PP support website. For information on accessing the site, refer to the
support documentation that shipped with your storage system. Refer only to these
documents for prescribed installation information when using SSR212PP-Series
storage systems.

The rest of this section describes what to do before you install PowerPath on the host.

[] Obtain up-to-date information. Check the SSR212PP support website for the most current
information:

B Release Notes. We update the PowerPath release notes periodically and post them on
the Web.

B Patches and notices. Review the patch ReadMe files to determine which patches (if
any) you want to install after PowerPath, and whether those patches have any added
prerequisites that must be met before you install PowerPath.

B Check Microsoft-certified drivers. To check whether a PowerPath driver is signed,
refer to the procedure in Appendix A, .

[] Choose a convenient time for the installation. Installing PowerPath requires you to reboot
the host. Plan to install or upgrade PowerPath when a reboot will cause minimal
disruption to your site.

Installing PowerPath on a host connected exclusively to SSR212PP-Series arrays
does not require a license. PowerPath 4.5.x provides full support with or without a
PowerPath license when the host is connected exclusively to SSR212PP-Series
arrays.

[l Verify that your environment meets the requirements in:

B Environment and System Requirements section of the PowerPath Version 4.5 Release
Notes. That section describes minimum hardware and software requirements for the
host and supported storage systems.

m  Chapter 3, PowerPath Configuration Requirements, in the PowerPath Product Guide.
That chapter describes the host-storage system interconnection topologies that
PowerPath supports.

[] Configure HBA drivers.

2 Intel Storage System SSR212PP PowerPath 4.5 for Windows: Installation and Administration Guide
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A CAUTION

Be sure to follow HBA driver configuration guidelines outlined in the Support
Matrix and product documentation. Using improper settings can cause erratic
failover behavior, such as greatly increased I/O delays.

[] For hosts connected to storage arrays via a Fibre Channel switch (that is, a fabric),
configure the HBAs using persistent binding for SCSI target IDs.

A CAUTION

Failure to do so could result in data loss or corruption of data.

[] Do not connect multiple paths from the HBAs to the storage system interface ports, hubs,
or switches, or zone multiple paths, until you have installed PowerPath and shut down the
host.

[] A failed redundancy state can occur if PowerPath is installed on a host with mirrored
disks. This state only happens if disk management applications (that use the dmadmin
service) are running when PowerPath is installed. To prevent this, it is recommended that
you close all disk management applications (including diskmgmt.msc and diskpart.exe)
and stop the dmadmin service before installing PowerPath.

Host Connected to a Third-Party Array
Take note of the following before installing PowerPath on a host connected to a third-
party array:

0 Uninstall any third-party multipathing software before installing PowerPath. This
is necessary to avoid contention between the multipathing applications.

O If you do not want PowerPath to manage a third-party array, be sure that you do
not select that array during the Custom Setup phase of PowerPath installation.

Booting from a Storage Array Device
Refer to the following documents for instructions on configuring a storage array device as
the boot device:

B Fibre Channel with Emulex Host Bus Adapters in the Windows Environment (P/N
300-001-157), available on the Emulex website:
http://www.emulex.com/ts/docoem/emc/pdfs/win.pdf.

B Fibre Channel with QLogic Host Bus Adapters in the Windows Environment (P/N
300-001-164), available on the Qlogic website:
http://download.qlogic.com/drivers/31940/QLogic_Windows.pdf.

Install PowerPath after you have configured the storage array boot device. As noted
above, there should only be a single path from the host to the storage array device when
you install PowerPath. Connect the additional paths after installing PowerPath and
rebooting the host (as indicated in the following installation instructions).

Prepare Clustered Environment
If you are installing PowerPath in a clustered environment:
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[

Prepare the cluster environment.

Refer to Chapter 4, , for information on installing PowerPath in a new or existing cluster.
Prepare Browser

If you do not have the proper browser installed, you may view help files directly from the
installation CD.

Check the online help for the Licensing Tool for help on registering PowerPath. If you do
not already have a license in the registry, the Licensing Tool displays during the
installation process; see STEP 10 on page 5 under "Installing PowerPath Using
InstallShield" on page 4. Access online help for this application from the Help button or
F1 key. If you do not have the proper browser installed, you may run this help file directly
from the installation CD.

Installing PowerPath Using InstallShield

STEP 1.

STEP 2.

STEP 3.

STEP 4.

For a new PowerPath installation, do not connect multiple paths from the HBAs to
the storage system interface ports or switches until you have installed PowerPath
and shut down the host. The correct procedure is: Confirm that there is a single path
from the host to each device on the array, install PowerPath, shut down the host,
connect additional cables from the host to the array, and then power on the host, as
described in this procedure.

To load the CD-ROM:
a. Insert the PowerPath installation CD-ROM in the CD-ROM drive.

If autoplay is enabled, your browser launches and displays the Getting Started page.
You can install the software from the Installation section by clicking the appropriate
link for your operating system. Choose Run this program from its current location (or a
similar message depending on your browser) and click OK to proceed with the
installation.

The message used in the prompt above varies according to which browser and
version you have installed on your system.

b. If autoplay is not enabled, from the Start menu, select Run.

In the Run window, either browse to or enter the name of the PowerPath installation
program and click OK.

On the Choose Language Setup screen, select the language for this installation from the
drop down list and click OK. Localized versions of the PowerPath installer and licensing
tool are available in Brazilian Portuguese, English, French, German, Italian, Korean,
Japanese, Latin American Spanish, and simplified Chinese.

In the setup wizard welcome window, click Next.

Intel Storage System SSR212PP PowerPath 4.5 for Windows: Installation and Administration Guide
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STEP 5. On the AX150 Series screen, select Yes if this host connects exclusively to SSR212PP-
Series arrays and click Next. Otherwise, select No and click Next.

STEP 6. Enter your name and organization on the Customer Information screen and click Next.
STEP 7. Use the Custom Setup screen to configure PowerPath support for EMC Invista devices

and/or third party arrays, and to install PowerPath in a directory other than the default
directory (if desired).

It is recommended that you install PowerPath in the default directory. No action is
required to install in the default directory.

To install PowerPath in a different (non-default) directory, click Change. The setup wizard
prompts you to browse to your destination folder. Select the destination folder, and click
OK.

A CAUTION

Do not specify the Windows System directory for your system (specified by the
%SYSTEMROOT% environment variable). PowerPath will not function correctly
if it is installed in this directory.

STEP 8. Click Next.

STEP 9. In the Ready to Install the Program dialog box, click Install.
If you do not already have a license in the registry, the EMC Licensing Tool displays.

The EMC Licensing Tool does not display when PowerPath is being installed on a
host connected exclusively to SSR212PP-Series arrays. Continue with STEP 11.

STEP 10. When prompted by the EMC Licensing Tool, enter your 24-digit registration number in
the License Key field. Click Add, and then OK.

You may enter multiple registration numbers as PowerPath is supported on
different storage devices. If you are upgrading from a previous version, PowerPath
saves the existing 12-digit license key, and no input is required.

Type the registration number exactly as written on the card. To reduce common
typographical errors, the License Key field accepts either uppercase or lowercase
letters, and certain numbers and letters are interchangeable. Specifically, entering
the alphabetic letters O, 1, S, and B is equivalent to entering the numbers, 0,
1,5, and 8.

If you have additional questions about entering licenses, consult the online help file

by pressing F1 from the EMC Licensing Tool. You must have Internet Explorer 5.0
or higher to view these files. If you do not have this browser installed, you may still
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view the help file, EmcLicTool.chm, directly from the \help folder on the PowerPath
installation CD.

STEP 11. In the InstallShield Wizard Completed dialog box, click Finish.
STEP 12. When the setup wizard asks whether you want to reboot the host, click No.
STEP 13. From the Start menu, select Shut Down.

STEP 14. In the Shut Down Windows dialog box, select Shut Down from the list, and click OK.

After the host shuts down, follow the instructions in "After You Install" on page 9 to
connect additional paths from the host to the array.

Installing PowerPath from the Command Line

PowerPath supports two types of CLI installations:

m  Silent installations Unattended PowerPath installation using command-line
parameters; does not require any user input.

® Interactive installations Attended PowerPath installation that requires user input.

For a new PowerPath installation, do not connect multiple paths from the HBAs to
the storage system interface ports or switches until you have installed PowerPath
and shut down the host. The correct procedure is: Confirm that there is a single path
from the host to each device on the array, install PowerPath, shut down the host,
connect additional cables from the host to the array, and then power on the host.

Silent Installation

To perform a silent PowerPath installation, use a command line in the following format
(type all on one line):

drive\folde\EMCPPplatform.4.5.x.GA.exe Is IV"Iq IL*v pathToLogfile [ property=propertyValue 1* "
where:

® drive is the CD drive letter, for example, C.

® folder is either W2000 or W2003.

® platform is either W2000, W2003_32, W2003_ia64, or W2003_x64.
e x is the release level, for example, 0.

® pathToLogfile is the complete path to the log file, for example,
C:\logs\PPremove.log.

® property=propertyValue is one or more optional properties.

Table 1, "Silent Installation Variables" describes the variables used in the syntax above.
Table 2, "Optional Properties" describes the optional properties.

6 Intel Storage System SSR212PP PowerPath 4.5 for Windows: Installation and Administration Guide
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TABLE 1. Silent Installation Variables

Is Informs InstallShield that this is a silent installation.

v Directs InstallShield to pass the following information string (enclosed in
quotes) to the Microsoft Installer (MSI).

/q Informs the Microsoft Installer that is a quiet installation (no user interface).

IL*v file Directs the Microsoft Installer to write verbose output to the file specified

with this option. The target directory for the log file must exist before starting
a silent installation using the logging option (as required by the Windows
installer engine).
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TaeLe2.  Optional Properties

LICENSENUM=licenseKey The value must be a valid license or no license will be saved.

INSTALL_DRIVE=drive The drive on which PowerPath will be installed. By default,
PowerPath is installed on the C: drive.

¥  The installation only uses first character entered and must be a
valid drive letter or the default drive will be used.

¥  TheINSTALL_DRIVE value will be ignored if the same version
of PowerPath is already installed on the host.

NO_REBOOT=1 If NO_REBOQT=1, the host will not reboot after PowerPath is
installed.

NOTES:
1. All properties must be in capital letters or the information will not be passed to installer.

After PowerPath is installed, shut down the host and follow the instructions in
"After You Install" on page 9 to connect additional paths from the host to the array.

Examples of Silent Installations
The following are all valid command lines for silent installations:

m  Silent installation logging, set the PowerPath License, set the PowerPath install drive,
disable reboot at completion:

EMCPPplatform.4.5.x.GA.exe /s Iv"/q /L*v C:\logs\PPsetup.log
LICENSENUM=0000-0000-0000-0000-0000-0000 INSTALL_DRIVE=Z NO_REBOOT=1"

m  Silent installation with no logging, set the PowerPath License, disable reboot at
completion:

EMCPPplatform.4.5.x.GA.exe /s Iv'/q LICENSENUM=0000-0000-0000-0000-0000-0000
NO_REBOOT=1"

Interactive Installation

To perform an interactive installation of PowerPath using the CLI, use a command line in
the following format (type all on one line):

drive:\folde\EMCPPplatform.4.5.x.GA.exe V"IL*v pathToLogfile [ property=propertyValue 1* "
where:

drive is the CD drive letter, for example, C.
folder is either W2000 or W2003.
platform is either W2000, W2003_32, W2003_ia64, or W2003_x64.

x is the release level, for example, O.

pathToLogfile is the complete path to the log file, for example,
C:\logs\PPremove.log.

® property=propertyValue is one or more optional properties.

Intel Storage System SSR212PP PowerPath 4.5 for Windows: Installation and Administration Guide
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After You

Table 3, "Interactive Installation Variables" describes the variables used in the syntax
above. See Table 2 "Optional Properties" on page -8 for a description of the optional
properties.

TABLE 3. Interactive Installation Variables

Iv Directs InstallShield to pass the following information string (enclosed in
quotes) to the Microsoft Installer (MSI).

IL*V file Directs the Microsoft Installer to write verbose output to the file specified
with this option. The target directory for the log file must exist before starting
an interactive installation using the logging option (as required by the
Windows installer engine).

After PowerPath is installed, shut down the host and follow the instructions in
"After You Install" on page 9 to connect additional paths.

Examples of Interactive Installations
The following are all valid command lines for interactive installations:

m Interactive installation with logging, set the PowerPath License, set the PowerPath
install drive, disable reboot at completion:
EMCPPplatform.4.5.x.GA.exe " /L*v C:\logs\PPsetup.log
LICENSENUM=0000-0000-0000-0000-0000-0000 INSTALL_DRIVE=Z NO_REBOOT=1"
m Interactive installation with no logging, set the PowerPath License, disable reboot at
completion:

EMCPPplatform.4.5.x.GA.exe IV'"LICENSENUM=0000-0000-0000-0000-0000-0000
NO_REBOOT=1"

Install

STEP 1.

This section describes what to do after you install PowerPath on a Windows host:

With the host shut down, connect the remaining cables from the HBAs to the storage
system interface ports, hubs, or switches, or zone multiple paths. For cabling instructions,
refer to the product guide for your storage system.

Power on the host. PowerPath is now fully configured, with multiple paths to logical
devices.

If the environment is Fibre Channel, make sure zones are configured appropriately. If you

have not already done so, check the SSR212PP support website for any patches to
PowerPath 4.5 x, and install any required patches.

Verify and Save the Configuration

Power on the host. PowerPath is fully configured with multiple paths to logical devices
and (if appropriate) correct zones when you boot.
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STEP 2. Verify the correctness of your configuration by running the following at the command
prompt:

powermt display
powermt display dev=all
powermt display ports.

STEP 3. Save the configuration to the file powermt.custom by running the following command:

powermt save.

For descriptions of powermt commands, refer to the PowerPath Product Guide.

If PowerPath sees no devices, but the devices are seen by the operating system,
verify that the devices are configured for PowerPath support, as suggested in
"Before You Install" on page 2.

Installing a PowerPath Patch

Every patch release is accompanied by a Readme file that describes how to install the
patch. Before you install a patch, PowerPath 4.5 x for Windows 2000 and Windows Server
2003 must be installed on the host.

Patches and Configuration Files

PowerPath stores configuration information in a file that may be loaded at boot time. After
a patch is applied, the format of the configuration file may change so it is no longer
backward compatible. To avoid losing configuration information, follow the steps in the
appropriate section below.

Saving and Loading Configurations from the Command Line

To save and load configurations with the powermt utility, follow the steps below. Refer to
the PowerPath Product Guide for more information on the powermt utility.

m  Before installing a patch, run the powermt save command back up your old
configuration file. You can use the powermt load command to restore your
configuration if you uninstall the patch later.

m  After installing a patch and verifying the configuration is correct, run the powermt
save command to save your configuration. This ensures the configuration file is
updated to the current format.

Saving and Loading Configurations from the PowerPath
Administrator

To save and load configurations from PowerPath Administrator, follow these steps:

m  Before installing a patch, back up your configuration file. Use the backup to restore
your configuration if you uninstall the patch later.

m  After installing a patch and verifying the configuration is correct, save your
configuration. This ensures the configuration file is updated to the current format.

10 Intel Storage System SSR212PP PowerPath 4.5 for Windows: Installation and Administration Guide
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Saving Configurations

From PowerPath Administrator, you can save your configuration any time. If you do not
save your changes, they will be lost on reboot. You can save PowerPath Administrator
settings to a configuration file. The file records the serial numbers, mode, policy, and
priority for each configured path.

PowerPath configuration files are distinct from the Microsoft Management Console
(MMC) configuration files. If you close the MMC window, MMC prompts you to
save the MMC settings. These settings are not the same as the PowerPath
Administrator settings. Saving the MMC console settings does not save your
PowerPath configuration changes; therefore, these changes will be lost unless you
follow the next procedure.

Use the following procedure to save a PowerPath configuration:
STEP 1. In the scope pane, select the PowerPathAdmin root node.

STEP 2. To save the configuration with the default filename, right-click the root node and select
All Tasks » Save Config for Reboot... .

To save the configuration with a different name, select Save Config as... . In the Save As
dialog box, navigate to your desired directory, enter a filename, and click Save.

In the PowerPath Administrator, you can save your configuration at any time.
However, the active PowerPath configuration on your desktop does not reflect the
saved configuration until you run the Save Config for Reboot... or the

Save Config as... command. Saving a configuration overwrites any previous
configuration data.

Loading Configurations

You can load the last known reboot state or alternatively, a previously saved PowerPath
Administrator configuration file. Use the following procedure to load a configuration:

STEP 1. In the scope pane, select the PowerPathAdmin root node.

STEP 2. To load a previously saved PowerPath configuration, right-click the root node and select
All Tasks » Load Config File... .

The first time you run PowerPath Administrator, there is a default configuration. If
you make changes to this configuration using the PowerPath Administrator that you
want to keep, save the configuration.

To load the last known reboot state, right click the root node and select
All Tasks » Load Reboot Config... .

Upgrading Windows Operating Systems

You can upgrade your Windows operating system from:
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®  Windows NT 4.0 to Windows 2000, see "Upgrading from Windows 2000 Systems" on
page 12.

®  Windows 2000 to Windows Server 2003, see "Upgrading from Windows 2000
Systems" on page 12.

Upgrading from Windows 2000 Systems

To upgrade your Windows 2000 operating system to Windows 2003, choose the scenario
that applies:

m [fyou are running PowerPath versions 3.0.5 to 4.1.1 on Windows 2000 and wish to
upgrade to the Windows Server 2003 platform, refer to the PowerPath Windows
Server 2003 Upgrade Package Release Notes on the Powerlink website
(http://powerlink.emc.com).

The PowerPath Windows Server 2003 Upgrade Package alleviates the need
for the removing and reinstalling PowerPath to perform the operating system
upgrade.

m  If you are running PowerPath versions 4.3 or later on Windows 2000 and wish to
upgrade to the Windows Server 2003 platform, install the Windows Server 2003
operating system following the instructions in your Microsoft documentation.

It is not necessary to remove PowerPath 4.5.x before upgrading your
operating system.

Licensing Tool

Use the Licensing Tool to register PowerPath. The Licensing Tool is displayed during
PowerPath installation when the host is nof connected exclusively to SSR212PP-Series
arrays. To manage licenses, you may launch it at any time, as well, by selecting PowerPath
Licensing Tool from the Start » Programs » EMC menu.

Use the Licensing Tool to add or remove licenses. For more information, see the online
help for the Licensing Tool (press F1) or launch the help file, EMCLicTool.chm, resident on
the PowerPath CD under the \help directory.

You must have Internet Explorer 5.0 or higher to view the online help files from the
Licensing Tool by pressing F1. If you do not have this browser installed, you may
still view the help file directly from the online help file, EMCLicTool.chm, resident
on the SSR212PP Resource CD under the \help directory.
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Removing PowerPath 4.5 for
Windows

This chapter describes how to remove the PowerPath software from a Windows 2000 or
Windows Server 2003 host.

m "Before You Remove PowerPath" on page 13

®  "Removing PowerPath from a Windows Host" on page 13

m  "Removing PowerPath Using Add/Remove Programs" on page 14
|

"Removing PowerPath from the Command Line" on page 14

Before You Remove PowerPath

Before you remove PowerPath from the host:

[] Check the SSR212PP support website for the most current information. We update release
notes periodically and post them on the Web.

[] Stop any application actively sending 1/0. In addition, you may want to close any

remaining applications and client files to avoid warning messages when rebooting after
the uninstall.

Removing PowerPath from a Windows Host

CAUTION

Data corruption is possible if multiple paths remain on a system after PowerPath
has been removed. Make sure that you remove any redundant paths during the
uninstall process, following the instructions in this section.

You can remove PowerPath:

m  Using the Add/Remove Programs wizard.

®  From the command line.
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Removing PowerPath Using Add/Remove Programs

STEP 1.

STEP 2.

STEP 3.

STEP 4.

STEP 5.

Open the Control Panel, double-click Add/Remove Programs.

On the Add/Remove Programs panel, select the installed version of PowerPath and click
Remove.

When prompted to remove PowerPath, click Yes.
When prompted to restart the host, click No.

Disconnect redundant paths to the storage systm:
a. From the Start menu, select Shut Down.
b. In the Shut Down Windows dialog box, select Shut Down from the list, and click OK.

c. With the host shut down, disconnect redundant cables from the HBAs to the storage
system interface ports.

SAN configurations may have multiple logical configurations per physical
connection. Ensure that no redundant paths exist.

d. Reboot the host. PowerPath is completely removed from the host.

Removing PowerPath from the Command Line

14

You can remove PowerPath from the command line:

m  Silently, which requires no user input.

m Interactively, which requires user input.

Remember to disconnect redundant cables from the HBAs to the storage system
interface ports after PowerPath has been removed and before the host is rebooted.
SAN configurations may have multiple logical configurations per physical
connection. Ensure that no redundant paths exist before rebooting.

Silent Removal

To perform a silent removal of PowerPath from the command line, use the following
syntax (enter the entire command on one line):

drive:\foldehNEMCPPplatform.4.5.x.GA.exe Is N'"Iq /L*v pathToLogfile [property=propertyValue]* "
where:

® drive is the CD drive letter, for example, C.

® folder is either W2000 or W2003.
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® platform is either W2000, W2003 32, W2003_ia64, or W2003_x64.
® xis the release level, for example, O.

® pathToLogfile is the complete path to the log file, for example,
C:\logs\PPremove.log.

®  property=propertyValue 1S zero or more optional properties.

Table 4, "Silent Removal Variables", describes the variables used in the syntax above.
Table 5, "Optional Properties" describes the optional properties.

TABLE 4. Silent Removal Variables

Is Informs InstallShield that this is a silent removal.

v Directs InstallShield to pass the following information string (enclosed in
quotes) to the Microsoft Installer (MSI).

Iq Informs the Microsoft Installer that is a quiet removal (no user interface).

IL*v file\ Directs the Microsoft Installer to write verbose output to the file specified

with this option. The target directory for the log file must exist before
starting a silent removal using the logging option (as required by the
Windows installer engine).

TaeLe5.  Optional Properties

NO_REBOOT=1 If NO_REBOOT=1, the host will not reboot after PowerPath is
removed.

Be sure to specify to NO_REBOOT=1. Otherwise, PowerPath will
reboot before you can remove the redundant connections.

PPREMOVE=1 When PPREMOVE=1, PowerPath will be removed in the normal
fashion, leaving driver files and corresponding registry entries.
PPREMOVE=2 When PPREMOVE=2, PowerPath will be removed. All driver files

and corresponding registry entries will be removed as well.

NOTES:
1. All properties must be in capital letters or the information will not be passed to installer.

Silent Removal Example

The following is an example of a silent clean removal with logging enabled, reboot
disabled:

EMCPPplatform.4.5.x.GA.exe /s Iv"Iq /L*v C:\logs\PPcleanremoval.log NO_REBOOT=1
PPREMOVE=2"

Interactive Removal from the Command Line

To perform an interactive removal of PowerPath from the command line, use the
following syntax (enter the entire command on one line):

drive:\folde\EMCPPplatform.4.5.x.GA.exe V" pathToLogfile [property=propertyValue]* "
where:

® drive is the CD drive letter, for example, C.
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Table 6,

folder 1s either W2000 or W2003.

platform 1s either W2000, W2003_32, W2003_ia64, or W2003_x64.
x 1s the release level, for example, O.

pathToLogfile is the complete path to the log file, for example,
C:\logs\PPremove.log.

property=propertyValue 18 Zero or more optional properties.

"Interactive Removal Variables", describes the variables used in the syntax above.

See Table 5 "Optional Properties" on page -15 for a description of the optional properties.

TABLE 6.

Interactive Removal Variables

v

Directs InstallShield to pass the following information string (enclosed in
quotes) to the Microsoft Installer (MSI).

IL* file

Directs the Microsoft Installer to write verbose output to the file specified
with this option. The target directory for the log file must exist before
starting an interactive removal using the logging option (as required by the
Windows installer engine).

Examples of Interactive Removals
The following are all valid command lines for interactive removals:

m Interactive removal with logging enabled, reboot disabled:
EMCPPplatform.4.5.x.GA.exe " [L*v C:\logs\PPremove.log NO_REBOOT=1 PPREMOVE=1"

m [nteractive clean removal with logging enabled, reboot disabled:
EMCPPplatform.4.5.x.GA.exe " [L*v C:\logs\PPcleanremoval.log NO_REBOOT=1

PPREMOVE=2"
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PowerPath 4.5 for Windows
Administrator

The chapter introduces the PowerPath Administrator for Windows 2000 and Windows
Server 2003. The topics include:

®  "Overview" on page 17
"PowerPath Monitor" on page 17
"PowerPath Administrator" on page 19

"Local or Remote Administration" on page 24

"Saving Console Settings" on page 32

Overview

The PowerPath Administrator graphical user interface for Windows 2000 and Windows
Server 2003 consists of two applications:

m  PowerPath Monitor continuously monitors your PowerPath configuration and can
alert you of status changes. See the following section, "PowerPath Monitor" on
page 17.

m  PowerPath Administrator provides a graphical user interface for configuring,
monitoring, and managing PowerPath devices. See "PowerPath Administrator" on
page 19.

PowerPath Monitor

PowerPath Monitor (on the taskbar of your Windows desktop) continuously monitors the
status of your PowerPath configuration and can be set to alert you with visual and audible
cues when the status changes.

For example, if a path fails, the icon changes accordingly (see Table 8) and depending on
the Notification settings you choose on the Options tab of the PowerPath Admin (root node)
Properties dialog box (see PowerPath Administrator online help for Windows 2000 and
Windows Server 2003), PowerPath Monitor may sound an alarm, restore the PowerPath
Administrator Main Window, flash the taskbar icon, or any combination thereof.
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Table 7 shows each taskbar icon and the status it represents.

TABLE 7. PowerPath Monitor Taskbar Icons

Optimal All configured paths are operating properly.

Degraded Some but not all paths have failed.

All Failed All configured paths have failed.

Server Not Responding  Cannot communicate with Monitor
service. This occurs if the PowerPath Administrator Suite encoun-
tered errors during initialization.

\v bR AR

All non-Optimal monitor icons appear only if you have checked Flash Taskbar Icon
on the Options tab of the EMC PowerPath Admin (root node) Properties dialog box.
The root node is the top-level view of your configuration and represents the host
being managed by PowerPath.

Launching MMC With the PowerPath Snap-in

You can use PowerPath Monitor to launch Microsoft Management Console (MMC) with
the PowerPath Snap-in and to notify you of PowerPath status changes if you are running it
on a local host.

The PowerPath Administrator Monitor monitors the local host only. It does not
remotely monitor the status of another host. The icon is only present on the
Windows taskbar on the host with PowerPath Administrator installed. If you are
running PowerPath for the first time on a remote host you must start the application
according to the instructions under "Local or Remote Administration" on page 24.

To launch the Microsoft Management Console (MMC) with the PowerPath Snap-in, do
one of the following:

m  Double-click the PowerPath Monitor icon on the Windows taskbar to launch the
default MMC console with the PowerPath Snap-in.

m  Right click the PowerPath Monitor icon to display the following context menu options:
e PowerPath Administrator launches PowerPath Administrator.
® Close Monitor closes the PowerPath Administrator Monitor.

®  From the Start menu, select
Programs » EMC » PowerPath » PowerPath Administrator.
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PowerPath Administrator

For Windows 2000 and Windows Server 2003, the PowerPath Administrator runs as a
snap-in program within Microsoft Management Console (MMC). You can use MMC and
the PowerPath Snap-in to monitor a local or remote host. Refer to "Local or Remote
Administration" on page 24.

The PowerPath Administrator is a graphical user interface for configuring, monitoring,
and managing PowerPath devices. The PowerPath Administrator continuously monitors a
multipath storage-system environment and automatically updates the configuration
information displayed.

You can use PowerPath Administrator to set up and change your device configuration and
manage physical and logical path components. The PowerPath Administrator displays a
hierarchical representation of paths, logical devices, and HBAs.

PowerPath Administrator displays the components of a PowerPath system as objects.
PowerPath Administrator icons represent the PowerPath objects in your configuration.
The type of icon reflects the state or status of the particular object selected. Table 8 on
page -21 and Table 9 on page -23 display PowerPath Administrator icons.

PowerPath Administrator Panes
As part of MMC, the PowerPath Administrator has two panes:

m  The scope pane displays PowerPath objects in a hierarchical list that can be expanded
or collapsed.

m  The result pane provides a view of configuration statistics for PowerPath objects
selected in the scope pane.

Figure 1 shows a sample PowerPath Administrator display.

"Hi EmcPowerPathw2K3_3zbit - [Console Root',EMC PowerPathAdmin'Disks] - o [=] 54|
B Fls Action Wew Fovorbes Window  Help |=ls 5]‘
& =] | = |
|1 Console Root DiskNurnber | Path Status | Path State | PathMode | 10s/Sec | Q-10s | Errors | Storage Class | Path Metric | Storage ID | Storage Mame | Der
=B eMC Powerpathidmin | | = pigk ogs Cptimal Cpen Active 26 0 0 Symmetrix 6l6 000183500585 - 00:
0 storage firays SODisko0s  Optimal Cpen Active 41 o o Symmetric a6 000183500565 - o0
g . IDisk006é  Optimal Open Active 25 0 0 Symmetric 6l 000183500565 - i
Acaptery =opiskons  Optimal Cpen Active 956 o o CLARION 12012 WREODLONID, ., delifious? 600
I0isk00  Optimal Open Active 285 0 0 CLARION 12/12 WREDDIODID.,.  delirious2 800

SDisk 010 Optimal open Active 194 0 0 CLARION 1212 WREDDIODIO...  delirious? 800

30isk011 Optimal Open Active 181 [ [ CLARION 1212 WREDDIODID.,.  delirious2 2l

SDisk01z  Optimal open Active 189 0 0 CLARION 1212 WREDDIODID.,.  delirious? 800

SDisk013  Optimal Open Active 176 0 0 CLARION 12/12 WREDDIODID.,.  delirious2 800

=Disk 014 Optimal open Active 167 0 0 CLARION 1212 WREDDIODID.,.  delirious? i

Sbisk01s  Optimal Open Active 181 0 0 CLARION 12f12 WREDDIODID.,.  delirious2 800

SDisk 016 Optimal open Active 181 0 0 CLARION 1212 WREDDIODID...  delirious? 800

S0isk017 Optimal Open Active 196 0 0 CLARION 12/12 WREDDIODID.,.  delirious2 800

4| | |

Scope pane Result pane

FIGURE 1. Sample PowerPath Administrator Display
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PowerPath Administrator Device Properties Dialog Box

You can use most PowerPath Administrator functions through the tabs available from the
device Properties dialog boxes of PowerPath objects:

PowerPath Admin (Root Node) Properties Use this to show root node details, set
local or remote host options, set error notification options, set Auto-Restore, and view
array management information. To display this tab, select the root node in the scope
pane, right-click, and select Properties.

The root node is the top-level view of your configuration and represents the
host being managed by PowerPath. The Root Node Properties dialog box
contains a Details, Computer, and Options tab. (The Computer tab is present
only when you are connected to a remote host). The Options tab contains a
Notification box, an Auto-Restore box, and an Array Management Information
box.

Storage Array Properties Use this to show storage array details. To display this
tab, select a storage array, right-click, and select Properties.

Storage Array Port Properties Use this to show storage array port details. To
display this tab, select a storage array port, right-click, and select Properties.

Adapter Properties Use this to show adapter details and change modes on the
adapter. To display this tab, select an adapter, right-click, and select Properties.

Disk Properties Use this to show disk details, change modes on the disk, and
change load balancing policies and priorities. To display this tab, select a disk, right-
click, and select Properties.

Path Properties Use this to show path details and change the mode of a path. To
display this tab, select a path, right-click, and select Properties.

The previous examples illustrate most common PowerPath Administrator
functions. For complete information on using on using all PowerPath Administrator
functions, refer to PowerPath Administrator online help for Windows 2000 and
Windows Server 2003.

If you do not have the Internet Explorer 5.0 browser or higher installed on your
system, you will be unable to launch the PowerPath online help files for Windows
2000 or Windows Server 2003 from the MMC console.
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Icons: Standard, Unlicensed, and Unknown Conditions

Table 8 shows icons for standard, unlicensed, unknown, and mismatched states.
Standard icons represent a configuration in which PowerPath is optimal.

TaeLe8.  PowerPath Administrator Icons
Standard | Unlicensed | Unknown | Mismatche
Root Node Graphical
representatlon of the host and top ? w Not
level view of your configuration. / Applicable

Storage Array An attached storage

system that provides logical devices {1 Q v

which are managed by PowerPath. = £ - ot
Applicable

Storage Array Port Identifies a e

port within a specific storage array (g % (3‘ Not

that provides I/0 paths to the logical Applicable

devices.

Disk A logical device managed by

PowerPath. Logical devices are disk = - %E ; 2' Not

devices presented by the storage Applicable
system.

Adapter A device that provides an
interface between the SCSI or Fibre
Channel bus and the computer I/O
bus. An adapter can have multiple
paths associated with it.

Path The logical or physical I/O
path from the host to the storage L 4 %:: a 3
system, including the HBA, cable, and L o

interface port.

:

H Not
Applicable

See the online help for more information on icons and their significance.
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Icons: Known Failure Conditions

When a path fails, the failure propagates through other PowerPath Administrator objects.
These objects are displayed in a hierarchy in the scope pane and also display in the result
pane. These known failure icons represent configurations that are less than optimal.

Table 9 shows known failure icons; that is, icons for degraded; failed; unlicensed and
degraded; and unlicensed and failed conditions. Degraded PowerPath objects are
represented by a red slash through the standard object icon. (Since a path is either open or
closed, the path icon is never shown as degraded.) Failed PowerPath objects are
represented by a red X through the standard object icon.

The definition of degraded and failed status depends on the context shown in Table 9 . For
example, an unlicensed version of PowerPath with degraded or failed paths displays icons
combining elements of both the unlicensed and degraded icons.

Unless specified otherwise, all icons display in both the summary and details panes.
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TABLE 9.

Storage Root Node
Port Array

Storage Array

PowerPath
device

Path

Intel Storage System SSR212PP PowerPath 4.5 for Windows: Installation and Administration Guide

PowerPath

Administrator is
identifying a degradation
within the managed

PowerPath
Administrator is in
a failed state.

PowerPath Administrator Object Icons

: : Unlicensed and Unlicensed and Failed
Degraded Icon Failed Icon Degraded Icon

PowerPath

Administrator is
unlicensed and
identifying a degradation
within the managed
environment.

PowerPath

Administrator is
unlicensed and in a failed
state.

environment.

One or more (but
m not all) paths to the
storage array have
failed or are in a

7 All paths to the
ﬂ specific array have
failed. This array is
not available.

PowerPath

Administrator is

unlicensed. One or
more (but not all) paths
to the array have failed or
are in a degraded state.

PowerPath

Administrator is

unlicensed. All
paths to the specific array
have failed.This disk is
not available.

degraded state.

3 One or more (but
not all) paths to the

storage array port have

failed or are in a

E All paths to the
specific array port
have failed. This array
port is not available.

PowerPath

Administrator is
unlicensed. One or more
(but not all) paths to the
array port have failed or
are in a degraded state.

PowerPath

Administrator is
unlicensed. All paths to
the specific array port
have failed. This disk is
not available.

degraded state.

7A One or more (but
not all) paths to the

disk device have failed.

% All paths to the

specific disk device
have failed. This disk is
not available.

PowerPath

Administrator is
unlicensed. One or more
(but not all) paths to the
disk device have failed.

PowerPath

Administrator is
unlicensed. All paths to
the specific disk device
have failed. This disk is
not available.

H One or more (but
not all) adapters
have either failed or
degraded. Displays in the
Adapters folder in the
scope pane.

One or more (but not all)
paths have failed on the
specific adapter. Displays
in the individual adapter
folders under Adapters in
the scope pane or in the
result pane when
Adapters is selected from
the scope pane.

H All paths on this
adapter to this disk
have failed.

PowerPath
Administrator is
unlicensed.

One or more (but not all)
adapters have either
failed or degraded.
Displays in the Adapters
folder in the scope pane.

One or more (but not all)
paths have failed on the
specific adapter. Displays
in the individual adapter
folders under Adapters in
the scope pane or in the
result pane when
Adapters is selected from
the scope pane.

PowerPath

Administrator is
unlicensed. All paths on
this adapter to this disk
have failed.

Not Applicable

One or more of the

hardware
components that make up
the path has failed;
therefore, the entire path
failed.

Not Applicable

PowerPath

Administrator is
unlicensed and one or
more of the hardware
components that
comprise the path has
failed, therefore, the
entire path fails.
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Local or Remote Administration

24

With MMC and the PowerPath Snap-in, you can monitor a local host or a remote host.

®  Local Administration PowerPath Administrator is installed on the local host by

default. The installation process provides a preconfigured .msc file to launch the
Microsoft Management Console (MMC). Once PowerPath is installed, you can use
PowerPath to monitor the local host immediately.

® To launch MMC with the PowerPath Snap-in, from the Start menu, select
Programs » EMC » PowerPath » EMC PowerPathAdmin.

® The above path starts the PowerPath Snap-in and the MMC console on the local
host with no other action required. However, there may be scenarios in which you
need to add the PowerPath Snap-in to a new MMC console. For example, you
may want to create another instance of PowerPath Administrator on the local host
or you may have deleted the PowerPath Snap-in and want to add it again. To add
the PowerPath Snap-in to the MMC console to monitor a local host, refer to "Set
Local Host Option" on page 24.

Remote Administration If you want to monitor a remote host that has PowerPath
3.0.5 or higher for Windows 2000 or Windows Server 2003 installed, you may supply
the credentials for remote access to that host. To add the PowerPath Snap-in to
monitor a remote host with PowerPath 3.0.5 or higher installed, refer to "Set Remote
Host Option" on page 28.

When PowerPath 3.0.5 or higher is installed for Windows 2000 or Windows Server
2003 on more than one host, you may use the Remote Host Option to monitor any
host from any other host.

Set Local Host Option

STEP 1. Open the MMC

a.
b.

C.

From the Start menu, select Run... .

In the Open field of the Run dialog box, type: mmc

I Xl

ﬂ Tputs thun i o i e e, alcler, document, ar
Inbwerest resours, and sindcssn sl opee i For

opere [ =

Click OK.

An MMC Console appears. The MMC title bar displays Consolel. Within this pane is
the Console Root. Initially this folder is empty. However, once the snap-in is added,
this folder will contain the PowerPath Administrator (and other snap-ins you may add)
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and display them as expandable icons under the Console Root folder. See Figure 1 on

page 19.

HETE—_—_—— . aoiw
gl weks e D FE @ i
r_‘-_mﬂ

| b e feotm | = = W@ §

Trew: | Pgvortes | |

El -

The figures used in this section and in the following section, Set Remote
Host Option were taken from Windows 2000 systems. There may be slight
differences between the MMC console running on Windows 2000 and the
console running on Windows Server 2003. In these scenarios, the difference
has been noted in these instructions.

STEP 2. Add the PowerPath Administrator Snap-in.

a. From the MMC console, select Console » Add/Remove Snap-in... .
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On Windows Server 2003 systems, select File » Add/Remove Snap-in... .

The Add/Remove Snap-in window appears:

CTETT TR Xl

Lk o e hr B S P o e i ) Dl W
el LT =] =i
T 5

o |

| g I Can

b. Inthe Add/Remove Snap-in window, click Add.

¢. From the Add Standalone Snap-in window, select PowerPath Administration and click

Add.
Add Standalone Snap-in " el |

Available Standalone Snap-ins:
Snap-in | Wendor |;|
'.g IP Security Policy Management Microzoft Corporation
@ Link. to web Address Microsoft Corporation

& Local Ugers and Groups Microzoft Corporation

ﬁ Performance Logs and Alerts Microzoft Corporation

2 PoverPath Administration EMLC Corporation

@ Femote Desklops Microzoft Corporation
(5: Femovable Storage Management Microzoft Corporation
Hesultant Set of Policy Microzoft Corporation e
B Routing and Remate Access Microzoft Corporation
@ Security Configuration and Analpsiz  Microzoft Corporation LI

r— Description

Copyright € 1997-2003 EMC Corporation. _

All rights reserved. All trademarks used herein are the property of their
respective owners.

Add Close
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d. In the PowerPathAdmin dialog box, select Local Computer.

oo o [EMIE PrownsPalivikmin 0
Sedac e coampien Ban. neapen el B

L B o i i Leagon b e
e e vl s
1% Ltal bominser e comgulel S Dbk B g ot

T i comgupn

Uzer K
Dromrasn Hims:
P ars=mat

e. Click Finish.

f. Inthe Add Standalone Snap-in dialog box, click Add to add another snap-in or click

Close.
g. Inthe Add/Remove Snap-in dialog, click OK.

PowerPath Administrator is now added to the MMC console.
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You can now use PowerPath Administrator to configure, manage, and monitor PowerPath
devices. Once you have changed your configuration, you can save this configuration.
Refer to "Saving and Loading Configurations from the PowerPath Administrator" on
page 10.

Set Remote Host Option

STEP 1. Open the MMC.
a. From the Start menu, select Run... .

b. In the Open field of the Run dialog box, type: mmc

T

hﬂh_ahmﬂi&uu,t
wrd ik For s

e [EH |

[T | cawa | e |

¢. Click OK.

An MMC Console appears. The MMC title bar displays Consolel. Within this pane is
the Console Root. Initially this folder is empty. However, once the snap-in is added,
this folder will contain the PowerPath Administrator (and other snap-ins you may add)
and display them as expandable icons under the Console Root folder. See Figure 1 on
page 19.

| s wpdos w0 FH @

[ e feete || = = BR 0
Tiee | Favasts | — I

- - -

The figures used in this section and in the previous section, Set Local Host Option
were taken from Windows 2000 systems. There may be slight differences between
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the MMC console running on Windows 2000 and the console running on Windows
Server 2003. In these scenarios, the difference has been noted in these instructions.

STEP 2. Add the PowerPath Administrator Snap-in.

a. From the MMC console, select Console » Add/Remove Snap-in... .

On Windows Server 2003 systems, select File » Add/Remove Snap-in... .

The Add/Remove Snap-in window appears:

CIESTT T 1l
Sundatora | Estersmrs |
Lo o o 0 i et et o Dl R

omeses G o o

| | J
I N

b. In the Add/Remove Snap-in window, click Add.
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¢. From the Add Standalone Snap-in window, select PowerPath Administration and click
Add.

Add Standalone Snap-in B 21l

Available Standalone Snap-ins:

| Snap-in | Wendor | ;I
'.g IP Security Policy Management Microzoft Corporation
@ Link. to web Address Microsoft Corporation
& Local Ugers and Groups Microzoft Corporation
ﬁ Performance Logs and Alerts Microzoft Corporation
v PawerPath Admiristration EMLC Corporation
@ Femote Desklops Microzoft Corporation
(5: Femovable Storage Management Microzoft Corporation
Hesultant Set of Policy Microzoft Corporation e
E Fiouting and Remote Access Microzoft Corporation

@ Security Configuration and Analpsiz  Microzoft Corporation LI
=4

r— Description
Copyright € 1997-2003 EMC Corporation.

All nights reserved. All trademarks used herein are the property of their
respective owners.

fdd Close |

d. Inthe PowerPathAdmin dialog box, select Another Computer.

1 porrathaden =
‘walcaman b [ MT PowerF sthfdmn
Teplaci e commpade e oo el DO ~

e
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e T ] ’ Erimin |
Uz W {
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TR I
[ Feon ] coel |
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e. Enter the computer name or browse for the remote computer..

Browse for Computer 2=l

Select the computer this snapin will manage.

I Computers Near Me
E--i My Metwork Places

Entire: Metwork.
Computers Near Me

Ok I Cancel

f. In the Browse for Computer dialog box, click OK.

g. Enter your User Name, Domain Name, and Password.

CEETT x
e b ML ol sl s, [
Sl e commpaiie e e el ERERRg ] i

Gl B o e L

e P vl AR R
Ll o Pl e S Coreok e i

L T Frimmim |
Lt Horar: iim“

[ Hsens Irl.'.-r

h. Click Finish.

The User Name, Domain Name, and Password fields are subsequently
available for editing from the root node Properties page if you are using
MMC to monitor a remote host. For more information, refer to Set Remote
Host Options topic in the PowerPath Administrator online help for Windows
2000 and Windows Server 2003.

i. Inthe Add Standalone Snap-in window, click Add to add another snap-in or click
Close.
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j- Inthe Add/Remove Snap-in window, click OK. PowerPath Administrator is now
added to the MMC console.
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You can now use PowerPath Administrator to configure, manage, and monitor PowerPath
devices. Once you have changed your configuration, you can save this configuration.
Refer to "Saving and Loading Configurations from the PowerPath Administrator" on
page 10.

Saving Console Settings

The MMC console enables you to display the PowerPath Snap-in data in many ways. If
you change your MMC console configuration (for example, you may resize columns,
change column displays, or change column sort order), you may want to save these new
MMC console settings.

If you close the MMC console itself, or the PowerPath Snap-in within the MMC console,
MMC prompts you, Save console settings to <filename>.msc? Click Yes to save the latest
console settings. By default, MMC console settings are saved as consolel.msc in the
%SystemDrive%)\Programs\Administrative Tools folder.

You may save the console settings anytime with the Console » Save menu option in the
MMC console. To save the file with a different name or to a different location, use the
MMC console Console » Save As menu option.
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PowerPath Iin an
MSCS Cluster

This chapter describes how to install PowerPath on a Microsoft Cluster Server (MSCS)
cluster. The chapter covers the following topics:

®  "[nstalling PowerPath and MSCS" on page 33
m "Integrating PowerPath into an Existing MSCS Cluster" on page 33

Installing PowerPath and MSCS

If you are installing PowerPath and MSCS for the first time, install PowerPath first, and
then install MSCS. Installing PowerPath first avoids having to disrupt cluster services at a
later time. Refer to the Microsoft MSCS documentation for complete information on
planning, configuring, managing, and troubleshooting MSCS.

Integrating PowerPath into an Existing MSCS Cluster

You can integrate PowerPath into an existing MSCS cluster without shutting down the
cluster, if there is close coordination between the nodes and the storage system.

Each node in a cluster can own a distinct set of resources. Node A is the primary node for
its resources and the failover node for node B s resources. Conversely, node B is the
primary node for its resources and the failover node for node A's resources.

Refer to the Microsoft MSCS documentation for complete information on planning,
configuring, managing, and troubleshooting MSCS.

If after installing PowerPath on the cluster, you test node failover by disconnecting
all cables for a LUN or otherwise disrupting the path between the active host and
the array, Windows logs event messages indicating hardware or network failure and
possible data loss. If working correctly, the cluster will failover to a node with an
active path and you can ignore the messages from the original node as logged in the
event log. (You should check the application generating /O to see if there are any
failures. If there are none, everything is working normally.)

The following procedure describes how to install PowerPath on a two-node cluster. You
can also install PowerPath on clusters with greater than two nodes. In these cases, the
appropriate action is noted where applicable for nodes with greater than two clusters.

To add PowerPath to an existing MSCS cluster (with MSCS running on both nodes),
follow these steps:
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STEP 1. Move all resources to Node A.

a. Start the MSCS Cluster Administrator utility, select
Start » Programs » Administrative Tools » Cluster Administrator.

The Cluster Administrator window appears (Figure 2).
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FIGURE 2. Cluster Administrator

b. In the left pane of the Cluster Administrator window, select all groups owned by node
B.

¢. To move the resources to node A, select File » Move Group.

Alternatively, select Move Group by right-clicking all group names under Groups in
the left pane.

d. To pause node B, click node B and select File » Pause Node.

This keeps the node from participating in the cluster during PowerPath installation.

STEP 2. Install PowerPath on Node B:

a. Install PowerPath on node B, following the steps in "Installing PowerPath Using
InstallShield" on page 4.

b. Shut down node B.

In a cluster with greater than two nodes, install PowerPath on these other nodes. For
example, in a four-node cluster, replace node B with nodes B, C, and D in Step 4 of
the previous section, Move all resources to Node A., and also in Steps 1 and 2, above.

STEP 3. Configure additional paths between the storage system and Node B:
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If necessary, reconfigure the storage system so its logical devices appear on multiple
ports.

If necessary, install additional HBAs on node B.

Connect cables for new paths between node B and the storage system.
Power on node B.

To resume node B, click node B and select File » Resume Node.

In a cluster with greater than two nodes, configure additional paths between the
storage system and these other nodes. For example, in a four-node cluster, replace
node B with nodes B, C, and D in steps b, ¢, d, and e above.

STEP 4. Move all resources to Node B:

C.

In the left pane of the Cluster Administrator window, select all groups.
To move the resources to node B, select File » Move Group.

In a cluster with greater than two nodes, move all resources to any of the remaining
nodes. For example, in a four-node cluster, replace node B with any combination of
nodes B, C, and D to which you want to move resources. For example, you could
move resources to nodes B and C or move them to B, C, and D, or any permutation of
nodes B, C, and D taken alone or together.

To pause node A, click node A and select File » Pause Node.

STEP 5. Install PowerPath on Node A:

a.

b.

Install PowerPath on node A, following the steps in "Installing PowerPath Using
InstallShield" on page 4.

Shut down node A.

Configuring Additional Paths between the Storage System and Node A

1.

1.

2
3.
4

If necessary, configure the storage system so its logical devices appear on multiple
ports.

If necessary, install additional HBAs on node A.
Connect cables for new paths between node A and the storage system.
Power on node A.

To resume node A, click node A and select File, Resume Node.

Returning Node A’s Resources to Node A

1.

5.

Using the MSCS Cluster Administrator utility, select all groups previously owned by
node A.

To move the resources back to node A, select File, Move Group.
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Appendix: WHQL
Certification

This appendix describes the procedure to check whether a PowerPath driver is signed.
The appendix contains the following section:

WHQL-Certified Driver

STEP 1.

STEP 2.

STEP 3.

STEP 4.

STEP 5.

STEP 6.

STEP 7.

STEP 8.

STEP 9.

STEP 10.

On Windows 2000 and Windows Server 2003, the PowerPath driver is WHQL certified.
To view the PowerPath driver signature:

From the Start menu, select Settings » Control Panel.

From the Control Panel, open the System applet.

Click the Hardware tab.

Click Device Manager.

Expand the SCSI and RAID controllers node.

Right-click EMS device bus.

In the EMS device bus dialog box, select Properties.

Click the Driver tab.

Check the Digital Signer field to see the driver signature information.

When the driver is signed, the field contains information about the organization that
assigned the driver.
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Appendix: List of Files
Changed by PowerPath

This appendix lists files that are added or modified by PowerPath installation and use. It
also describes Registry changes that result from PowerPath installation. The topics
include:

m  "File Changes on Windows 2000 and Windows Server 2003" on page 39
m  "Driver Files Installed Into System Directories" on page 41

m  "Registry Changes Caused by PowerPath Installation" on page 42

File Changes on Windows 2000 and Windows Server 2003

By default, PowerPath places the following files in the

%SystemDrive%\Program Files(x86) directory on x64 platforms, and in the
%SystemDrive%\Program Files directory on all other platforms (or another directory, if
you specified one when installing PowerPath):

EMC\PowerCommon\EmcLicTool.exe
EMC\PowerCommon\EmcLicTool _CHS.dII
EMC\PowerCommon\EmcLicTool_FRA.dII
EMC\PowerCommon\EmcLicTool_DEU.dII
EMC\PowerCommon\EmcLicTool _ITA.dII
EMC\PowerCommon\EmcLicTool_JPN.dII
EMC\PowerCommon\EmcLicTool_KOR.dll
EMC\PowerCommon\EmcLicTool_PTB.dll
EMC\PowerCommon\EmcLicTool_ESP.dII

EMC\PowerCommon\Emcp_lic_rtl.dll
EMC\PowerPath\Emcp_cg_rtl.dll
EMC\PowerPath\Emcp_mp_rtl.dll
EMC\PowerPath\EmcPowerPath.msc

The file EmcPowerPath.msc is the MMC file for Windows 2000 and Windows
Server 2003 (64-bit) .

The file EmcPowerPathW2K3_32bit.msc is the MMC file for Windows Server
2003 (32-bit) only.

EMC\PowerPath\EmcPowerPathW2K3_32bit.msc
EMC\PowerCommon\EmcPowMon.exe
EMC\PowerPath\EmcPowPN22.dll
EMC\PowerCommon\EmcPowRes.dll
EMC\PowerCommon\EmcPowSrv.exe
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EMC\PowerPath\EmcAdminSvr.exe
EMC\PowerPath\EmcAdminProxy.dll
EMC\PowerPath\EmcPowerPathAdmin.dll
EMC\PowerCommon\EmcpSvcErr.dll
EMC\PowerPath\powermt.exe
EMC\PowerPath\powerprotect.exe

To support 32-bit applications (for example, Navisphere) on ia64-bit Windows Server
2003, PowerPath creates the following files and, by default, places them in the
%SystemDrive%\Program Files (x86)\EMC\PowerPath directory (or another directory, if
you specified one when installing PowerPath):

EMC\PowerPath\Emcp_mp_rtl.dll
EMC\PowerPath\EmcPowCG22.dll

Base Driver Files

The following PowerPath base driver files are copied during installation:

EMC\PowerCommon\Drivers\EmcpBase.sys
EMC\PowerCommon\Drivers\EmcpBase.cat
EMC\PowerCommon\Drivers\EmcpBase.inf
EMC\PowerCommon\Drivers\EmcpCoinst30.dl|
EMC\PowerCommon\Drivers\EmcpCG.sys
EMC\PowerCommon\Drivers\EmcpMP.sys
EMC\PowerCommon\Drivers\EmcpMPC.sys
EMC\PowerCommon\Drivers\EmcpMPAA.sys
EMC\PowerCommon\Drivers\EmcpMPAP.sys
EMC\PowerCommon\Drivers\EmcpSAPI.sys
EMC\PowerCommon\Drivers\EmcpHR.sys

Class Driver Files

The following PowerPath class driver files are copied during installation:

EMC\PowerCommon\Drivers\EmcpClass.sys
EMC\PowerCommon\Drivers\EmcpClassCoinst.dll
EMC\PowerCommon\Drivers\EmcpHDSClass.inf
EMC\PowerCommon\Drivers\EmcpHDSClass.cat
EMC\PowerCommon\Drivers\EmcpHPClass.inf
EMC\PowerCommon\Drivers\EmcpHPClass.cat
EMC\PowerCommon\Drivers\EmcpHPQClass.inf
EMC\PowerCommon\Drivers\EmcpHPQClass.cat
EMC\PowerCommon\Drivers\EmcpIBMClass.inf
EMC\PowerCommon\Drivers\EmcpIBMClass.cat
EMC\PowerCommon\Drivers\EmcplnvistaClass.inf
EMC\PowerCommon\Drivers\EmcplnvistaClass.pnf
EMC\PowerCommon\Drivers\EmcpDGCClass.inf
EMC\PowerCommon\Drivers\EmcpDGCClass.cat
EMC\PowerCommon\Drivers\EmcpSYMMClIass.inf
EMC\PowerCommon\Drivers\EmcpSYMMClass.cat
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Driver Files Installed Into System Directories

The following PowerPath files are installed into system directories.

Driver Installation Information Files

The following PowerPath driver installation information files are installed by the
operating system when the plug-n-play system completes the driver installation:

%systemroot%\inAEmcpHDSClass.inf
%systemroot%\inAEmcpHDSClass.pnf
%systemroot%\inAEmcpHPClass.inf
%systemroot%\inAEmcpHPClass.pnf
%systemroot%\inAEmcpHPQClass.inf
%systemroot%\inAEmcpHPQClass.pnf
%systemroot%\inAEmcpIBMClass.inf
%systemroot%\inAEmcpIBMClass.pnf
%systemroot%\inAEmcplnvistaClass.inf
%systemroot%\inAEmcplnvistaClass.pnf
%systemroot%\inEmcpDGCClass.inf
%systemroot%\inAEmcpDGCClass.pnf
%systemroot%\inAEmcpSYMMClass.inf
%systemroot%\inAEmcpSYMMClass.pnf
%systemroot%\inAEmcpBase.inf
%systemroot%\inAEmcpBase.pnf

Base and Class Driver Coninstaller Files

The following PowerPath base and class driver files are installed by the operating system
when the plug-n-play system completes the driver installation:

%systemroot%\System32\EmcpCoinst30.dll
%systemroot%\System32\EmcpClassCoinst.dll
%systemroot%\System32\drivers\EmcpBase.sys
%systemroot%\System32\drivers\EmcpMPC.sys
%systemroot%\System32\drivers\EmcpCG.sys
%systemroot%\System32\drivers\EmcpMP.sys
%systemroot%\System32\drivers\EmcpMPAA.sys
%systemroot%\System32\drivers\EmcpMPAP.sys
%systemroot%\System32\drivers\EmcpSAPI.sys
%systemroot%\System32\drivers\EmcpHR.sys
%systemroot%\System32\drivers\EmcpClass.sys

PowerPath Signed Catalog Files

The following PowerPath signed catalog files are installed by the operating system when
the plug-n-play system completes the driver installation:

%systemroot%\System32\CatRoot{F750E6C3-38EE-11D1-85E5-00C04
FC295EE}\EmcpBase.cat

%systemroot%\System32\CatRoot\{F750E6C3-38EE-11D1-85E5-00C04
FC295EE}\EmcpHPClass.cat

%systemroot%\System32\CatRoot\{F750E6C3-38EE-11D1-85E5-00C04
FC295EE}NEmcpHPQClass.cat
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%systemroot%\System32\CatRoot\{F750E6C3-38EE-11D1-85E5-00C04
FC295EE}NEmcpHDSClass.cat

%systemroot%\System32\CatRoot\{F750E6C3-38EE-11D1-85E5-00C04
FC295EE}\EmcpIBMClass.cat

%systemroot%\System32\CatRoot\{F750E6C3-38EE-11D1-85E5-00C04
FC295EE}EmcplnvistaClass.cat

%systemroot%\System32\CatRoot\{F750E6C3-38EE-11D1-85E5-00C04
FC295EE}\EmcpDGCClass.cat!

%systemroot%\System32\CatRoot\{F750E6C3-38EE-11D1-85E5-00C04
FC295EE}NEmcpSYMMClass.cat2

Start Menu Shortcut Files

PowerPath creates the following Start menu shortcuts and places them in the
%SystemDrive%\Documents and Settings\All Users\Start Menu\Programs\EMC directory:

PowerPath\PowerPath Administrator.Ink
PowerPath Licensing Tool.Ink
PowerPath Monitor.Ink

PowerPath creates the following automatic startup file and places it in the
%SystemDrive%\Documents and Settings\All Users\Start Menu\Programs\Startup
directory:

PowerPath Monitor.Ink

Online Help Files
PowerPath copies the following online help files to the %systemroot%\Help directory:

EmcLicTool.chm
EmcPowerPathAdminMMC.chm
EmcLicToolCHS.chm
EmcLicToolFRA.chm
EmcLicToolDEU.chm
EmcLicToollITA.chm
EmcLicToolJPN.chm
EmcLicToolKOR.chm
EmcLicToolPTB.chm
EmcLicToolESP.chm

Registry Changes Caused by PowerPath Installation

Installing PowerPath on a host creates several entries in the Registry. The PowerPath
installation program removes these Registry entries if PowerPath is subsequently
uninstalled from your system. However, the Microsoft Installer also creates entries in the
Registry. These operating system induced entries remain on your system after uninstalling
PowerPath.

1. PowerPath 4.4.1 installations only.
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